Downloads

Subscribe to RSS feeds Downloads by clicking here
 

02/26/2015 - Traktor - MIDI Profiles

Please consult the included configuration document relative to your operating system in order to use the configuration file correctly (Requires Adobe Acrobat Reader) .

Traktor DJ Pro 2

Requires version 2.71







< Return to home page